The meaning of Apple's '647 patent

On December 19th the U.S. International Trade Commission (ITC) issued its final determination on Apple's claims against HTC of Taiwan, finding that HTC violated Section 337 of the Tariff Act by selling Android phones containing a technology that infringed a patent held by Apple. Section 337 enables the ITC to block importation into the US of foreign products that unfairly compete with domestic

Moving to FTB!

Today I am freezing my Blogger account and moving my blog to Freethought Blogs, a prominent all-atheist venture. This move will help me earn an income doing what I do, and give my work a higher profile so it will do more good. To make my life manageable I won't be posting here anymore, nor accepting any new comments on posts archived here, but I will keep this account open in order to keep its

On exa, zetta, and beyond

Anyone who lives in metric system countries knows what "kilo" means. A kilogram is 1000 grams, a kilometer is 1000 meters. Of course frequencies are measured in kiloHertz and in the computer world we have kilobits and kilobytes (although we are never quite sure if that is 1000 or 1024!).Most people even know that "mega" means a million. Power stations output megawatts of electricity, FM radios

My new CTO job

As you all probably know, I have changed job titles.I am now RAD's Chief Technology Officer instead of (or perhaps in addition to?) Chief Scientist.Our previous CTO, Prof. Daniel Kofman, is still in touch with the company. However, he is a bit busy since in addition to his position as Professor at Telecom ParisTech (formerly ENST), he has been appointed by France's Minister of Research and

MPLS-TP update

At the MPLS Working Group meeting this week it was announced that the core set of MPLS-TP RFCs have been finished.Indeed, we now have (I hope that I haven't missed too many):•RFC 5586 MPLS Generic Associated Channel (G-ACh and GAL)•RFC 5654 Requirements of an MPLS Transport Profile•RFC 5718 An In-Band Data Communication Network for MPLS-TP•RFC 5860 Requirements for OAM in MPLS Transport Networks•

The notorious IP checksum algorithm

I have been asked several times to explain the checksum calculation used in the IP suite (IPv4, TCP and UDP all utilize the same checksum algorithm).RFC 791, which defines IPv4, gives the checksum algorithm as follows :The checksum field is the 16 bit one's complement of the one'scomplement sum of all 16 bit words in the header. For purposes ofcomputing the checksum, the value of the checksum

Goal Theory Update


Here is the latest update on my moral theory work, for those keen on following it in-depth. This post is deliberately long, so those not so keen can skip this one. It assembles notes I've been sitting on for a while for lack of time to get them up.



On my last trip to St. Louis I debated a fellow atheist on my own goal theory of moral values vs. the desire utilitarianism of Alonzo Fyfe. That